<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) | !(IE 8)  ]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://celebritiesdeaths.com/xmlrpc.php"/> 
<link rel="stylesheet" type="text/css" href="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/ep8ewpnb/9u3x7.css" media="all"/><title>Bassam Saba Death -Dead - Obituary : Bassam Saba, a champion of Arabic music in the West has Died . - Deaths &amp; Obituaries</title><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://celebritiesdeaths.com/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:title" content="Bassam Saba Death -Dead - Obituary : Bassam Saba, a champion of Arabic music in the West has Died . - Deaths &amp; Obituaries"/><meta name="twitter:description" content="Bassam Saba Death -Dead &#8211; Obituary : Bassam Saba, a champion of Arabic music in the West has Died . Bassam Saba, a champion of Arabic music in the West has&nbsp;died&nbsp;, according to the following statements posted on social media on&nbsp;December 30. 2020. New York Times World @nytimesworld Bassam Saba, a champion of Arabic music… Read More &raquo;"/><meta name="twitter:creator" content="@cesummary"/><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="John Okoro"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="0 minutes"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://celebritiesdeaths.com/#website","url":"https://celebritiesdeaths.com/","name":"Celebrities Deaths","description":"Obituaries - See Which Celebrity Died Today","potentialAction":[{"@type":"SearchAction","target":"https://celebritiesdeaths.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://celebritiesdeaths.com/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/#primaryimage","inLanguage":"en-US","url":""},{"@type":"WebPage","@id":"https://celebritiesdeaths.com/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/#webpage","url":"https://celebritiesdeaths.com/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/","name":"Bassam Saba Death -Dead - Obituary:Bassam Saba, a champion of Arabic music in the West has Died . - Deaths &amp; Obituaries","isPartOf":{"@id":"https://celebritiesdeaths.com/#website"},"primaryImageOfPage":{"@id":"https://celebritiesdeaths.com/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/#primaryimage"},"datePublished":"2020-12-31T06:38:14+00:00","dateModified":"2020-12-31T06:38:14+00:00","author":{"@id":"https://celebritiesdeaths.com/#/schema/person/065da3498c4360561dc3e553e109ad8b"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://celebritiesdeaths.com/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/"]}]},{"@type":"Person","@id":"https://celebritiesdeaths.com/#/schema/person/065da3498c4360561dc3e553e109ad8b","name":"John Okoro","image":{"@type":"ImageObject","@id":"https://celebritiesdeaths.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=96&d=mm&r=g","caption":"John Okoro"},"description":"OUR TEAM JOHN OKORO John Okoro, is a Seasoned Journalist, scriptwriter, Movie producer/Director and Showbiz consultant. He is the founder and CEO of the multi Media conglomerate, Celebrities Deaths News, specializing in celebrities deaths news and obituaries He is a 2018 He has a degree in Political Science and Mass Communication.","sameAs":["https://celebritiesdeaths.com/","https://www.facebook.com/recentcelebritiesdeaths","https://twitter.com/cesummary"]}]}</script> <link rel='dns-prefetch' href='//platform-api.sharethis.com'/><link rel='dns-prefetch' href='//jetpack.wordpress.com'/><link rel='dns-prefetch' href='//s0.wp.com'/><link rel='dns-prefetch' href='//s1.wp.com'/><link rel='dns-prefetch' href='//s2.wp.com'/><link rel='dns-prefetch' href='//public-api.wordpress.com'/><link rel='dns-prefetch' href='//0.gravatar.com'/><link rel='dns-prefetch' href='//1.gravatar.com'/><link rel='dns-prefetch' href='//2.gravatar.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/><link rel='dns-prefetch' href='//c0.wp.com'/><link href='https://cdn.shortpixel.ai' rel='preconnect'/>    
<!--[if lt IE 9]><link rel='stylesheet' id='themonic-ie-css' href='https://celebritiesdeaths.com/wp-content/themes/iconic-one/css/ie.css' type='text/css' media='all'/><![endif]-->    <link rel="https://api.w.org/" href="https://celebritiesdeaths.com/wp-json/"/><link rel="alternate" type="application/json" href="https://celebritiesdeaths.com/wp-json/wp/v2/posts/311839"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://celebritiesdeaths.com/xmlrpc.php?rsd"/><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://celebritiesdeaths.com/wp-includes/wlwmanifest.xml"/><link rel='shortlink' href='https://celebritiesdeaths.com/?p=311839'/><link rel="alternate" type="application/json+oembed" href="https://celebritiesdeaths.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F"/><link rel="alternate" type="text/xml+oembed" href="https://celebritiesdeaths.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F&#038;format=xml"/>  <div id="fb-root"></div><meta property="og:type" content="article"/><meta property="og:title" content="Bassam Saba Death -Dead &#8211; Obituary : Bassam Saba, a champion of Arabic music in the West has Died ."/><meta property="og:url" content="https://celebritiesdeaths.com/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/"/><meta property="og:description" content="Bassam Saba Death -Dead &#8211; Obituary : Bassam Saba, a champion of Arabic music in the West has Died . Bassam Saba, a champion of Arabic music in the West has&nbsp;died&nbsp;, according to the f…"/><meta property="article:published_time" content="2020-12-31T06:38:14+00:00"/><meta property="article:modified_time" content="2020-12-31T06:38:14+00:00"/><meta property="og:site_name" content="Celebrities Deaths"/><meta property="og:image" content="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=512%2C512&amp;ssl=1"/><meta property="og:image:width" content="512"/><meta property="og:image:height" content="512"/><meta property="og:locale" content="en_US"/><meta name="twitter:creator" content="@DEATHSNEWS"/><meta name="twitter:text:title" content="Bassam Saba Death -Dead &#8211; Obituary : Bassam Saba, a champion of Arabic music in the West has Died ."/><meta name="twitter:image" content="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=240%2C240&amp;ssl=1"/><meta name="twitter:card" content="summary"/><link rel="icon" href="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=32%2C32&#038;ssl=1" sizes="32x32"/><link rel="icon" href="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=192%2C192&#038;ssl=1" sizes="192x192"/><link rel="apple-touch-icon" href="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=180%2C180&#038;ssl=1"/><meta name="msapplication-TileImage" content="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=270%2C270&#038;ssl=1"/> </head><body class="post-template-default single single-post postid-311839 single-format-standard custom-font-enabled"> <amp-ad width="100vw" height="320"
type="adsense"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-auto-format="rspv"
data-full-width=""><div overflow=""></div></amp-ad><div id="page" class="site"><header id="masthead" class="site-header" role="banner"><div class="io-title-description"> <a href="https://celebritiesdeaths.com/" title="Celebrities Deaths" rel="home">Celebrities Deaths</a> <br .../> <a class="site-description">Obituaries &#8211; See Which Celebrity Died Today</a></div><nav id="site-navigation" class="themonic-nav" role="navigation"> <a class="assistive-text" href="#main" title="Skip to content">Skip to content</a><ul id="menu-top" class="nav-menu"><li id="menu-item-294135" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294135"><a href="https://celebritiesdeaths.com/category/celebrities-deaths/">CELEBRITIES DEATHS</a></li><li id="menu-item-294150" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294150"><a href="https://celebritiesdeaths.com/category/comment-policy/">COMMENT POLICY</a></li><li id="menu-item-294152" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294152"><a href="https://celebritiesdeaths.com/about-us/">ABOUT US</a></li><li id="menu-item-294159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294159"><a href="https://celebritiesdeaths.com/contact-us/">CONTACT US</a></li><li id="menu-item-294163" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294163"><a href="https://celebritiesdeaths.com/follow-us-on-social-media/">FOLLOW US ON SOCIAL MEDIA</a></li></ul></nav><div class="clear"></div></header><div id="main" class="wrapper"><div id="primary" class="site-content"><div id="content" role="main"><div class='code-block code-block-5' style='margin: 8px 0; clear: both;'> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><article id="post-311839" class="post-311839 post type-post status-publish format-standard has-post-thumbnail hentry category-deathobituary"><header class="entry-header"><h1 class="entry-title">Bassam Saba Death -Dead &#8211; Obituary : Bassam Saba, a champion of Arabic music in the West has Died .</h1><div class="below-title-meta"><div class="adt"> By <span class="vcard author"> <span class="fn"><a href="https://celebritiesdeaths.com/author/admin/" title="Posts by John Okoro" rel="author">John Okoro</a></span> </span> <span class="meta-sep">|</span> <span class="date updated">December 31, 2020</span></div><div class="adt-comment"> <a class="link-comments" href="https://celebritiesdeaths.com/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/#respond">0 Comment</a></div></div></header><div class="entry-content"><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://celebritiesdeaths.com/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/" data-a2a-title="Bassam Saba Death -Dead – Obituary : Bassam Saba, a champion of Arabic music in the West has Died ."><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F&amp;linkname=Bassam%20Saba%20Death%20-Dead%20%E2%80%93%20Obituary%20%3A%20Bassam%20Saba%2C%20a%20champion%20of%20Arabic%20music%20in%20the%20West%20has%20Died%20." title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F&amp;linkname=Bassam%20Saba%20Death%20-Dead%20%E2%80%93%20Obituary%20%3A%20Bassam%20Saba%2C%20a%20champion%20of%20Arabic%20music%20in%20the%20West%20has%20Died%20." title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F&amp;linkname=Bassam%20Saba%20Death%20-Dead%20%E2%80%93%20Obituary%20%3A%20Bassam%20Saba%2C%20a%20champion%20of%20Arabic%20music%20in%20the%20West%20has%20Died%20." title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F&amp;linkname=Bassam%20Saba%20Death%20-Dead%20%E2%80%93%20Obituary%20%3A%20Bassam%20Saba%2C%20a%20champion%20of%20Arabic%20music%20in%20the%20West%20has%20Died%20." title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F&amp;linkname=Bassam%20Saba%20Death%20-Dead%20%E2%80%93%20Obituary%20%3A%20Bassam%20Saba%2C%20a%20champion%20of%20Arabic%20music%20in%20the%20West%20has%20Died%20." title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_blogger" href="https://www.addtoany.com/add_to/blogger?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F&amp;linkname=Bassam%20Saba%20Death%20-Dead%20%E2%80%93%20Obituary%20%3A%20Bassam%20Saba%2C%20a%20champion%20of%20Arabic%20music%20in%20the%20West%20has%20Died%20." title="Blogger" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div id="M579592ScriptRootC952655"></div><p>Bassam Saba Death -Dead &#8211; Obituary :  Bassam Saba, a champion of Arabic music in the West has Died .</p><p data-blogger-escaped-data-blogger-escaped-data-blogger-escaped-data-blogger-escaped-style="font-weight: 400;"><span data-blogger-escaped-data-blogger-escaped-data-blogger-escaped-data-blogger-escaped-style="font-weight: 400;"> Bassam Saba, a champion of Arabic music in the West has&nbsp;<a href="https://celebritiesdeaths.com/category/deathobituary/" target="_blank" rel="noopener">died</a>&nbsp;, according to the following statements posted on social media on&nbsp;</span>December 30. 2020.</p><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Bassam Saba, a champion of Arabic music in the West, has died of complications of Covid-19 <a href="https://t.co/qIxxQAddDn">https://t.co/qIxxQAddDn</a></p><div class="zDIiEzrs" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><p>&mdash; New York Times World (@nytimesworld) <a href="https://twitter.com/nytimesworld/status/1344498783355351041?ref_src=twsrc%5Etfw">December 31, 2020</a></p></blockquote><p></p><blockquote><p>New York Times World @nytimesworld Bassam Saba, a champion of Arabic music in the West, has died of complications of Covid-19</p></blockquote><div id="M579592ScriptRootC938202"></div></p><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-gravatar"><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'> <ins class="adsbygoogle"
style="display:block"
data-ad-format="fluid"
data-ad-layout-key="-cx-2d+b-2q+h3"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="6030412800"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><img alt src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=100&#038;d=mm&#038;r=g" class="avatar avatar-100 photo jetpack-lazy-image" height="100" width="100" itemprop="image" data-lazy-srcset="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=200&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=100&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' data-srcset='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=200&#038;d=mm&#038;r=g 2x' height='100' width='100' itemprop="image" data-src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=100&#038;d=mm&#038;r=g" class="avatar avatar-100 photo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="/><noscript><img alt='' src='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' itemprop="image"/></noscript></noscript></div><div class="saboxplugin-authorname"><a href="https://celebritiesdeaths.com/author/admin/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">John Okoro</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p><strong>OUR TEAM</strong></p><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><h2>JOHN OKORO</h2><p>John Okoro, is a Seasoned Journalist, scriptwriter, Movie producer/Director and Showbiz consultant.</p><p>He is the founder and CEO of the multi Media conglomerate, Celebrities Deaths News, specializing in celebrities deaths news and obituaries</p><div class='code-block code-block-4' style='margin: 8px 0; clear: both;'> <ins class="adsbygoogle"
style="display:block; text-align:center;"
data-ad-layout="in-article"
data-ad-format="fluid"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="7864619051"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><p>He is a 2018 He has a degree in Political Science and Mass Communication.</p></div></div><div class="clearfix"></div></div></div><footer class="entry-meta"> <span>Category: <a href="https://celebritiesdeaths.com/category/deathobituary/" rel="category tag">Deaths &amp; Obituaries</a></span> <span></span><div class="author-info"><div class="author-avatar"> <img alt src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=68&#038;d=mm&#038;r=g" class="avatar avatar-68 photo jetpack-lazy-image" height="68" width="68" data-lazy-srcset="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=136&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=68&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' data-srcset='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=136&#038;d=mm&#038;r=g 2x' height='68' width='68' data-src='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=68&#038;d=mm&#038;r=g' class='avatar avatar-68 photo lazyload' src='data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=='/><noscript><img alt='' src='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=68&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=136&#038;d=mm&#038;r=g 2x' class='avatar avatar-68 photo' height='68' width='68'/></noscript></noscript></div><div class="author-description"><h2>About John Okoro</h2><p><strong>OUR TEAM</strong><h2>JOHN OKORO</h2> John Okoro, is a Seasoned Journalist, scriptwriter, Movie producer/Director and Showbiz consultant.  He is the founder and CEO of the multi Media conglomerate, Celebrities Deaths News, specializing in celebrities deaths news and obituaries  He is a 2018 He has a degree in Political Science and Mass Communication.</p><div class="author-link"> <a href="https://celebritiesdeaths.com/author/admin/" rel="author"> View all posts by John Okoro <span class="meta-nav">&rarr;</span> </a></div></div></div></footer></article><nav class="nav-single"><div class="assistive-text">Post navigation</div><span class="nav-previous"><a href="https://celebritiesdeaths.com/angel-de-la-fuente-death-dead-obituary-fresno-police-officer-angel-de-la-fuente-has-died/" rel="prev"><span class="meta-nav">&larr;</span> Angel De La Fuente Death -Dead &#8211; Obituary : Fresno Police Officer Angel De La Fuente has Died .</a></span> <span class="nav-next"><a href="https://celebritiesdeaths.com/brodie-lee-death-dead-obituary-brodie-lee-has-died/" rel="next">Brodie Lee Death -Dead &#8211; Obituary : Brodie Lee has Died . <span class="meta-nav">&rarr;</span></a></span></nav><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/bassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died/#respond" style="display:none;">Cancel reply</a></small></h3><form id="commentform" class="comment-form"> <iframe title="Comment Form" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" data-src="https://jetpack.wordpress.com/jetpack-comment/?blogid=127677342&#038;postid=311839&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.2.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=cdc2d3421de5260e225737be4fbc85880a7a4fb8#parent=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F" class="jetpack_remote_comment lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="> </iframe> <!--<![endif]--></form></div><input type="hidden" name="comment_parent" id="comment_parent" value="" /><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div></div><div id="secondary" class="widget-area" role="complementary"><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="M579592ScriptRootC990616"></div></div></aside><aside id="text-2" class="widget widget_text"><p class="widget-title">CONTACTS US</p><div class="textwidget"><p>CONTACT CELEBRITIES DEATHS : 38 MARKET ROAD, ABA, ABIA STATE NIGERIA E-MAIL: jookco @ gmail.com</p></div></aside></div></div><footer id="colophon" role="contentinfo"><div class="site-info"><div class="footercopy">custom footer text left</div><div class="footercredit">custom footer text right</div><div class="clear"></div></div></footer><div class="site-wordpress"> <a href="https://themonic.com/iconic-one/">Iconic One</a> Theme | Powered by <a href="https://wordpress.org">Wordpress</a></div><div class="clear"></div></div><script data-ad-client="ca-pub-8705305398156930" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><noscript><style>.lazyload{display:none;}</style></noscript>     <script id='monsterinsights-frontend-script-js-extra'>var monsterinsights_frontend={"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/celebritiesdeaths.com","hash_tracking":"false"};</script>
<!--[if lt IE 9]><script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/mlc7ey5l/fqxdb.js"></script><![endif]-->
<script data-cfasync="false">(window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
var mi_version='7.14.0';
var mi_track_user=true;
var mi_no_track_reason='';
var disableStr='ga-disable-UA-171651658-1';
function __gaTrackerIsOptedOut(){
return document.cookie.indexOf(disableStr + '=true') > -1;
}
if(__gaTrackerIsOptedOut()){
window[disableStr]=true;
}
function __gaTrackerOptout(){
document.cookie=disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr]=true;
}
if('undefined'===typeof gaOptout){
function gaOptout(){
__gaTrackerOptout();
}}
if(mi_track_user){
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
__gaTracker('create', 'UA-171651658-1', 'auto');
__gaTracker('set', 'forceSSL', true);
__gaTracker('require', 'displayfeatures');
__gaTracker('require', 'linkid', 'linkid.js');
__gaTracker('send','pageview');
}else{
console.log("");
(function(){
var noopfn=function(){
return null;
};
var noopnullfn=function(){
return null;
};
var Tracker=function(){
return null;
};
var p=Tracker.prototype;
p.get=noopfn;
p.set=noopfn;
p.send=noopfn;
var __gaTracker=function(){
var len=arguments.length;
if(len===0){
return;
}
var f=arguments[len-1];
if(typeof f!=='object'||f===null||typeof f.hitCallback!=='function'){
console.log('Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason);
return;
}
try {
f.hitCallback();
} catch (ex){
}};
__gaTracker.create=function(){
return new Tracker();
};
__gaTracker.getByName=noopnullfn;
__gaTracker.getAll=function(){
return [];
};
__gaTracker.remove=noopfn;
window['__gaTracker']=__gaTracker;
})();
}</script>
<script src='//celebritiesdeaths.com/wp-content/cache/wpfc-minified/307cabkd/9u3yt.js' id='jquery-core-js'></script>
<script src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5fb8cdb411cd680019241de3' id='googleanalytics-platform-sharethis-js'></script>
<script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v8.0&appId=2679667082262512&autoLogAppEvents=1" nonce="oqWdgabD"></script>
<script>document.documentElement.className=document.documentElement.className.replace('no-js', 'js');</script>
<script>(function(){
(function (i, s, o, g, r, a, m){
i['GoogleAnalyticsObject']=r;
i[r]=i[r]||function (){
(i[r].q=i[r].q||[]).push(arguments)
}, i[r].l=1 * new Date();
a=s.createElement(o),
m=s.getElementsByTagName(o)[0];
a.async=1;
a.src=g;
m.parentNode.insertBefore(a, m)
})(window, document, 'script', 'https://google-analytics.com/analytics.js', 'ga');
ga('create', 'UA-171651658-1', 'auto');
ga('set', 'anonymizeIp', true);
ga('send', 'pageview');
})();</script>
<script>document.documentElement.classList.add('jetpack-lazy-images-js-enabled'
);</script>
<script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/cz3sihx/84l2n.js"></script>
<script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/1d1x0h4j/fqxdb.js" async></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/jp89fz6v/fqxdb.js" async></script>
<!--[if IE]><script>if(0===window.location.hash.indexOf('#comment-')){
window.location.hash=window.location.hash;
}</script><![endif]-->
<script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/6kkernx1/fqxdb.js" async></script>
<script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script>
<script async data-noptimize="1" src='https://d8a2i3w5.stackpathcdn.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js?ao_version=2.8.0'></script>
<!--[if IE]><script>if(0===window.location.hash.indexOf('#comment-')){
window.location.hash=window.location.hash;
}</script><![endif]-->
<script src='https://stats.wp.com/e-202053.js' async='async' defer='defer'></script>
<script>_stq=window._stq||[];
_stq.push([ 'view', {v:'ext',j:'1:9.2.1',blog:'127677342',post:'311839',tz:'0',srv:'celebritiesdeaths.com'} ]);
_stq.push([ 'clickTrackerInit', '127677342', '311839' ]);</script>
<script>document.addEventListener('DOMContentLoaded', function (){
var commentForms=document.getElementsByClassName('jetpack_remote_comment');
for (var i=0; i < commentForms.length; i++){
commentForms[i].allowTransparency=false;
commentForms[i].scrolling='no';
}});</script>
<script>(function (){
var comm_par_el=document.getElementById('comment_parent'),
comm_par=(comm_par_el&&comm_par_el.value) ? comm_par_el.value:'',
frame=document.getElementById('jetpack_remote_comment'),
tellFrameNewParent;
tellFrameNewParent=function (){
if(comm_par){
frame.src="https://jetpack.wordpress.com/jetpack-comment/?blogid=127677342&postid=311839&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.2.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=cdc2d3421de5260e225737be4fbc85880a7a4fb8#parent=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F" + '&replytocom=' + parseInt(comm_par, 10).toString();
}else{
frame.src="https://jetpack.wordpress.com/jetpack-comment/?blogid=127677342&postid=311839&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.2.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=cdc2d3421de5260e225737be4fbc85880a7a4fb8#parent=https%3A%2F%2Fcelebritiesdeaths.com%2Fbassam-saba-death-dead-obituary-bassam-saba-a-champion-of-arabic-music-in-the-west-has-died%2F";
}};
if('undefined'!==typeof addComment){
addComment._Jetpack_moveForm=addComment.moveForm;
addComment.moveForm=function(commId, parentId, respondId, postId){
var returnValue=addComment._Jetpack_moveForm(commId, parentId, respondId, postId),
cancelClick, cancel;
if(false===returnValue){
cancel=document.getElementById('cancel-comment-reply-link');
cancelClick=cancel.onclick;
cancel.onclick=function (){
var cancelReturn=cancelClick.call(this);
if(false!==cancelReturn){
return cancelReturn;
}
if(! comm_par){
return cancelReturn;
}
comm_par=0;
tellFrameNewParent();
return cancelReturn;
};}
if(comm_par==parentId){
return returnValue;
}
comm_par=parentId;
tellFrameNewParent();
return returnValue;
};}
document.addEventListener('DOMContentLoaded', function (){
var iframe_url="https:\/\/jetpack.wordpress.com";
if(window.postMessage){
if(document.addEventListener){
window.addEventListener('message', function(event){
var origin=event.origin.replace(/^http:\/\//i, 'https://');
if(iframe_url.replace(/^http:\/\//i, 'https://')!==origin){
return;
}
jQuery(frame).height(event.data);
});
}else if(document.attachEvent){
window.attachEvent('message', function(event){
var origin=event.origin.replace(/^http:\/\//i, 'https://');
if(iframe_url.replace(/^http:\/\//i, 'https://')!==origin){
return;
}
jQuery(frame).height(event.data);
});
}}
})
})();</script>
</body></html><!-- WP Fastest Cache file was created in 0.77535700798035 seconds, on 31-12-20 8:35:26 --><!-- need to refresh to see cached version -->