<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) | !(IE 8)  ]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://celebritiesdeaths.com/xmlrpc.php"/> 
<link rel="stylesheet" type="text/css" href="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/esu17hy/4kz02.css" media="all"/><title>Mo3 Death -Dead : Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today. - CELEBRITIES DEATHS</title><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:title" content="Mo3 Death -Dead : Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today. - CELEBRITIES DEATHS"/><meta name="twitter:description" content="Mo3 Death &#8211;Dead :  Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today.. Dallas rapper Mo3 has been pronounced dead after being shot on I-35 highway earlier today. The rapper was only 28 years old, according to a statement posted online on November 11.  2020. Dallas Police confirmed shooting took place and that the victim… Read More &raquo;"/><meta name="twitter:image" content="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?fit=2048%2C2560&amp;ssl=1"/><meta name="twitter:creator" content="@cesummary"/><meta name="twitter:label1" value="Written by"><meta name="twitter:data1" value="John Okoro"><meta name="twitter:label2" value="Est. reading time"><meta name="twitter:data2" value="3 minutes"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://celebritiesdeaths.com/#website","url":"https://celebritiesdeaths.com/","name":"Celebrities Deaths","description":"Obituaries - See Which Celebrity Died Today","potentialAction":[{"@type":"SearchAction","target":"https://celebritiesdeaths.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?fit=2048%2C2560&ssl=1","width":2048,"height":2560},{"@type":"WebPage","@id":"https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/#webpage","url":"https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/","name":"Mo3 Death -Dead :\u00a0Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today. - CELEBRITIES DEATHS","isPartOf":{"@id":"https://celebritiesdeaths.com/#website"},"primaryImageOfPage":{"@id":"https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/#primaryimage"},"datePublished":"2020-11-11T22:56:54+00:00","dateModified":"2020-11-12T00:05:32+00:00","author":{"@id":"https://celebritiesdeaths.com/#/schema/person/065da3498c4360561dc3e553e109ad8b"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/"]}]},{"@type":"Person","@id":"https://celebritiesdeaths.com/#/schema/person/065da3498c4360561dc3e553e109ad8b","name":"John Okoro","image":{"@type":"ImageObject","@id":"https://celebritiesdeaths.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=96&d=mm&r=g","caption":"John Okoro"},"description":"OUR TEAM JOHN OKORO John Okoro, is a Seasoned Journalist, scriptwriter, Movie producer/Director and Showbiz consultant. He is the founder and CEO of the multi Media conglomerate, Celebrities Deaths News, specializing in celebrities deaths news and obituaries He is a 2018 He has a degree in Political Science and Mass Communication.","sameAs":["https://celebritiesdeaths.com/","https://www.facebook.com/recentcelebritiesdeaths","https://twitter.com/cesummary"]}]}</script> <link rel='dns-prefetch' href='//jetpack.wordpress.com'/><link rel='dns-prefetch' href='//s0.wp.com'/><link rel='dns-prefetch' href='//s1.wp.com'/><link rel='dns-prefetch' href='//s2.wp.com'/><link rel='dns-prefetch' href='//public-api.wordpress.com'/><link rel='dns-prefetch' href='//0.gravatar.com'/><link rel='dns-prefetch' href='//1.gravatar.com'/><link rel='dns-prefetch' href='//2.gravatar.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/><link rel='dns-prefetch' href='//c0.wp.com'/><link href='https://cdn.shortpixel.ai' rel='preconnect'/>    
<!--[if lt IE 9]><link rel='stylesheet' id='themonic-ie-css' href='https://celebritiesdeaths.com/wp-content/themes/iconic-one/css/ie.css' type='text/css' media='all'/><![endif]-->   <link rel="https://api.w.org/" href="https://celebritiesdeaths.com/wp-json/"/><link rel="alternate" type="application/json" href="https://celebritiesdeaths.com/wp-json/wp/v2/posts/301612"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://celebritiesdeaths.com/xmlrpc.php?rsd"/><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://celebritiesdeaths.com/wp-includes/wlwmanifest.xml"/><link rel='shortlink' href='https://celebritiesdeaths.com/?p=301612'/><link rel="alternate" type="application/json+oembed" href="https://celebritiesdeaths.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F"/><link rel="alternate" type="text/xml+oembed" href="https://celebritiesdeaths.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F&#038;format=xml"/>  <div id="fb-root"></div><meta property="og:type" content="article"/><meta property="og:title" content="Mo3 Death -Dead : Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today."/><meta property="og:url" content="https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/"/><meta property="og:description" content="Mo3 Death -Dead :  Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today.. Dallas rapper Mo3 has been pronounced dead after being shot on I-35 highway earlier today. The rapper was only 28 …"/><meta property="article:published_time" content="2020-11-11T22:56:54+00:00"/><meta property="article:modified_time" content="2020-11-12T00:05:32+00:00"/><meta property="og:site_name" content="Celebrities Deaths"/><meta property="og:image" content="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?fit=960%2C1200&amp;ssl=1"/><meta property="og:image:width" content="960"/><meta property="og:image:height" content="1200"/><meta property="og:locale" content="en_US"/><meta name="twitter:creator" content="@DEATHSNEWS"/><meta name="twitter:text:title" content="Mo3 Death -Dead : Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today."/><meta name="twitter:image" content="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?fit=960%2C1200&#038;ssl=1&#038;w=640"/><meta name="twitter:card" content="summary_large_image"/><link rel="icon" href="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=32%2C32&#038;ssl=1" sizes="32x32"/><link rel="icon" href="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=192%2C192&#038;ssl=1" sizes="192x192"/><link rel="apple-touch-icon" href="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=180%2C180&#038;ssl=1"/><meta name="msapplication-TileImage" content="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/06/cropped-LOGO-3.png?fit=270%2C270&#038;ssl=1"/> </head><body class="post-template-default single single-post postid-301612 single-format-standard custom-font-enabled"> <amp-ad width="100vw" height="320"
type="adsense"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-auto-format="rspv"
data-full-width=""><div overflow=""></div></amp-ad><div id="page" class="site"><header id="masthead" class="site-header" role="banner"><div class="io-title-description"> <a href="https://celebritiesdeaths.com/" title="Celebrities Deaths" rel="home">Celebrities Deaths</a> <br .../> <a class="site-description">Obituaries &#8211; See Which Celebrity Died Today</a></div><nav id="site-navigation" class="themonic-nav" role="navigation"> <a class="assistive-text" href="#main" title="Skip to content">Skip to content</a><ul id="menu-top" class="nav-menu"><li id="menu-item-294135" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-294135"><a href="https://celebritiesdeaths.com/category/celebrities-deaths/">CELEBRITIES DEATHS</a></li><li id="menu-item-294150" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294150"><a href="https://celebritiesdeaths.com/category/comment-policy/">COMMENT POLICY</a></li><li id="menu-item-294152" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294152"><a href="https://celebritiesdeaths.com/about-us/">ABOUT US</a></li><li id="menu-item-294159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294159"><a href="https://celebritiesdeaths.com/contact-us/">CONTACT US</a></li><li id="menu-item-294163" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294163"><a href="https://celebritiesdeaths.com/follow-us-on-social-media/">FOLLOW US ON SOCIAL MEDIA</a></li></ul></nav><div class="clear"></div></header><div id="main" class="wrapper"><div id="primary" class="site-content"><div id="content" role="main"><div class='code-block code-block-5' style='margin: 8px 0; clear: both;'> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><article id="post-301612" class="post-301612 post type-post status-publish format-standard has-post-thumbnail hentry category-celebrities-deaths"><header class="entry-header"><h1 class="entry-title">Mo3 Death -Dead : Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today.</h1><div class="below-title-meta"><div class="adt"> By <span class="vcard author"> <span class="fn"><a href="https://celebritiesdeaths.com/author/admin/" title="Posts by John Okoro" rel="author">John Okoro</a></span> </span> <span class="meta-sep">|</span> <span class="date updated">November 12, 2020</span></div><div class="adt-comment"> <a class="link-comments" href="https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/#respond">0 Comment</a></div></div></header><div class="entry-content"> <img width="660" height="825" src="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?fit=660%2C825&amp;ssl=1" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?w=2048&amp;ssl=1 2048w, https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?resize=240%2C300&amp;ssl=1 240w, https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?resize=819%2C1024&amp;ssl=1 819w, https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?resize=768%2C960&amp;ssl=1 768w, https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?resize=1229%2C1536&amp;ssl=1 1229w, https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?resize=1638%2C2048&amp;ssl=1 1638w, https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?resize=660%2C825&amp;ssl=1 660w, https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?w=1330&amp;ssl=1 1330w, https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?w=1995&amp;ssl=1 1995w" data-lazy-sizes="(max-width: 660px) 100vw, 660px" data-lazy-src="https://i0.wp.com/celebritiesdeaths.com/wp-content/uploads/2020/11/mo3.jpg?fit=660%2C825&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"/><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/" data-a2a-title="Mo3 Death -Dead : Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today."><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F&amp;linkname=Mo3%20Death%20-Dead%20%3A%C2%A0Boosie%20Badazz%20Associate%20and%20Dallas%20Rapper%20Mo3%20Shot%20Dead%20Today." title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F&amp;linkname=Mo3%20Death%20-Dead%20%3A%C2%A0Boosie%20Badazz%20Associate%20and%20Dallas%20Rapper%20Mo3%20Shot%20Dead%20Today." title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F&amp;linkname=Mo3%20Death%20-Dead%20%3A%C2%A0Boosie%20Badazz%20Associate%20and%20Dallas%20Rapper%20Mo3%20Shot%20Dead%20Today." title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F&amp;linkname=Mo3%20Death%20-Dead%20%3A%C2%A0Boosie%20Badazz%20Associate%20and%20Dallas%20Rapper%20Mo3%20Shot%20Dead%20Today." title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F&amp;linkname=Mo3%20Death%20-Dead%20%3A%C2%A0Boosie%20Badazz%20Associate%20and%20Dallas%20Rapper%20Mo3%20Shot%20Dead%20Today." title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_blogger" href="https://www.addtoany.com/add_to/blogger?linkurl=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F&amp;linkname=Mo3%20Death%20-Dead%20%3A%C2%A0Boosie%20Badazz%20Associate%20and%20Dallas%20Rapper%20Mo3%20Shot%20Dead%20Today." title="Blogger" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div id="M579592ScriptRootC952655"></div><h2><b>Mo3 Death &#8211;<a href="https://celebritiesdeaths.com/category/deathobituary/">Dead </a>:  Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today..</b></h2><div><div style="font-size: medium;"><span style="font-weight: 400;"><span class="css-901oao css-16my406 r-1qd0xha r-ad9z0x r-bcqeeo r-qvutc0">Dallas rapper </span><span class="css-901oao css-16my406 r-1qd0xha r-b88u0q r-ad9z0x r-bcqeeo r-qvutc0">Mo3 has been</span><span class="css-901oao css-16my406 r-1qd0xha r-ad9z0x r-bcqeeo r-qvutc0"> pronounced </span><span class="css-901oao css-16my406 r-1qd0xha r-b88u0q r-ad9z0x r-bcqeeo r-qvutc0">dead</span><span class="css-901oao css-16my406 r-1qd0xha r-ad9z0x r-bcqeeo r-qvutc0"> after being shot on I-35 highway earlier today. The rapper was only 28 years old</span></span><span style="font-weight: 400;">, according to a statement posted online on November 11</span>.  2020.</div></div><div style="font-size: medium;"></div><div><div style="font-size: medium;">Dallas Police confirmed shooting took place and that the victim Mo3 was transported to a hospital, where he died from his injuries.</div></div><h2>How it Happened.</h2><p>Multiples sources confirmed that rapper MO3, whose real name is Melvin Noble , was shot multiple times while traveling northbound on I-35 when a car pulled up next to him and allegedly sprayed his vehicle with bullets. The rappers then lost control of his car and it crashed into a concrete barrier before coming to a halt.</p><blockquote class="twitter-tweet"><p dir="ltr" lang="en">Rapper <a href="https://twitter.com/hashtag/Mo3?src=hash&amp;ref_src=twsrc%5Etfw">#Mo3</a> Shot n killed &#x1f926;&#x1f3fe;&#x200d;&#x2642;&#xfe0f;&#x1f613; <a href="https://twitter.com/hashtag/Mo3shooting?src=hash&amp;ref_src=twsrc%5Etfw">#Mo3shooting</a> <a href="https://twitter.com/hashtag/mo3dead?src=hash&amp;ref_src=twsrc%5Etfw">#mo3dead</a> <a href="https://twitter.com/hashtag/mo3?src=hash&amp;ref_src=twsrc%5Etfw">#mo3</a> <a href="https://twitter.com/hashtag/Ripmo3?src=hash&amp;ref_src=twsrc%5Etfw">#Ripmo3</a> <a href="https://twitter.com/hashtag/mo3killed?src=hash&amp;ref_src=twsrc%5Etfw">#mo3killed</a> <a href="https://twitter.com/hashtag/mo3video?src=hash&amp;ref_src=twsrc%5Etfw">#mo3video</a> <a href="https://t.co/inAnLnU7mH">pic.twitter.com/inAnLnU7mH</a></p><p>— kariband$music (@karibandsmusic) <a href="https://twitter.com/karibandsmusic/status/1326625666964467713?ref_src=twsrc%5Etfw">November 11, 2020</a></p><div class="aF2tWDc0" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></blockquote><p></p><h2>What People are Saying</h2><blockquote class="twitter-tweet"><p dir="ltr" lang="en">This is the same freeway that <a href="https://twitter.com/hashtag/mo3?src=hash&amp;ref_src=twsrc%5Etfw">#mo3</a> was shot on. Do you think <a href="https://twitter.com/TRAPBOYFREDDY?ref_src=twsrc%5Etfw">@TRAPBOYFREDDY</a> had something to do with the shooting since they had beef ? &#x1f914; <a href="https://twitter.com/hashtag/mo3dead?src=hash&amp;ref_src=twsrc%5Etfw">#mo3dead</a> <a href="https://t.co/rOqpHGzH9j">pic.twitter.com/rOqpHGzH9j</a></p><p>— ᴛʜᴇ ᴅᴇᴇᴘ ᴇɴᴅ.&#x1f988; (@IGthrowedtbh) <a href="https://twitter.com/IGthrowedtbh/status/1326637729065660426?ref_src=twsrc%5Etfw">November 11, 2020</a></p></blockquote><p></p><div><div style="font-size: medium;"><p><iframe  width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen" data-src="https://www.youtube.com/embed/GBcNtt5VjH8" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></p><p>Mo3 Death happened few days after Atlanta rapper King Von, an up-and-comer in the Chicago drill scene, was killed  after being involved in a shooting in Atlanta on Friday morning, November 6.</p><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><p>&nbsp;</p><blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/CHdvmzgAZYI/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13"><div style="padding: 16px;"><p>&nbsp;</p><div style="display: flex; flex-direction: row; align-items: center;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div><div style="padding-top: 8px;"><div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div></div><div style="margin-left: auto;"><div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p>&nbsp;</p><p style="margin: 8px 0 0 0; padding: 0 4px;"><a style="color: #000; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none; word-wrap: break-word;" href="https://www.instagram.com/p/CHdvmzgAZYI/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer">#TSRTPrayersUp: #TeaMates, please keep the family of #Mo3 in your prayers as it’s being reported that he was shot on the Dallas freeway. ____________________________ According to @theshaderoom, they exclusively spoke to the Dallas Police Department and can confirm that a fatal shooting did occur on the RL Thornton Freeway. The identity of the victim has not been confirmed by police, even though people suspect the fatal victim is Mo3. ______________________________ We will continue to keep you updated #TeaMates ! &#x1f64f;&#x1f3fe;&#x2764;&#xfe0f;</a></p><p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by <a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px;" href="https://www.instagram.com/theshaderoomteens/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer"> The Shade Room Teens</a> (@theshaderoomteens) on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2020-11-11T20:59:12+00:00">Nov 11, 2020 at 12:59pm PST</time></p></div></blockquote><p></p><div class='code-block code-block-4' style='margin: 8px 0; clear: both;'> <ins class="adsbygoogle"
style="display:block; text-align:center;"
data-ad-layout="in-article"
data-ad-format="fluid"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="7864619051"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><h3>Tributes.</h3><h4>The following are some tributes posted on social media to honor the life and the legacy of the deceased.</h4><div style="font-size: medium;"><div style="font-size: medium;"><div style="font-weight: 400;"><div style="font-size: medium;"><div style="font-size: medium;"><div style="font-weight: 400;"><div></div><div></div><blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/CHdsR5pAW2q/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13"><div style="padding: 16px;"><p>&nbsp;</p><div style="display: flex; flex-direction: row; align-items: center;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div><div style="padding-top: 8px;"><div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div></div><div style="margin-left: auto;"><div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p>&nbsp;</p><p style="margin: 8px 0 0 0; padding: 0 4px;"><a style="color: #000; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none; word-wrap: break-word;" href="https://www.instagram.com/p/CHdsR5pAW2q/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer">RIP #Mo3 . It’s being reported that he was killed today while on the freeway in Dallas. He was reportedly shot in the head after a car pulled up and sent a hail of gunfire towards his vehicle. There may be more casualties. More details to come.</a></p><p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by <a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px;" href="https://www.instagram.com/akademiks/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer" class="broken_link"> DJ Akademiks</a> (@akademiks) on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2020-11-11T20:30:08+00:00">Nov 11, 2020 at 12:30pm PST</time></p></div></blockquote><p></p></div><blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/CHdsZV3M50j/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13"><div style="padding: 16px;"><p>&nbsp;</p><div style="display: flex; flex-direction: row; align-items: center;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div><div style="padding-top: 8px;"><div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div></div><div style="margin-left: auto;"><div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p>&nbsp;</p><p style="margin: 8px 0 0 0; padding: 0 4px;"><a style="color: #000; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none; word-wrap: break-word;" href="https://www.instagram.com/p/CHdsZV3M50j/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer">RIP #MO3&#8230; TMZ just confirmed he has passed away&#8230; Follow: @yojwayy</a></p><p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by <a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px;" href="https://www.instagram.com/hiphopstv/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer"> Hip Hops Tv&#x2122;</a> (@hiphopstv) on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2020-11-11T20:31:09+00:00">Nov 11, 2020 at 12:31pm PST</time></p></div></blockquote><p></p><p>&nbsp;</p><blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/CHdk33VA3LF/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13"><div style="padding: 16px;"><p>&nbsp;</p><div style="display: flex; flex-direction: row; align-items: center;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div><div style="padding-top: 8px;"><div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div></div><div style="margin-left: auto;"><div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p>&nbsp;</p><p style="margin: 8px 0 0 0; padding: 0 4px;"><a style="color: #000; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none; word-wrap: break-word;" href="https://www.instagram.com/p/CHdk33VA3LF/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer">Pray for #mo3 &#x1f64f;&#x1f3ff;</a></p><p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by <a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px;" href="https://www.instagram.com/akademiks/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer" class="broken_link"> DJ Akademiks</a> (@akademiks) on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2020-11-11T19:25:24+00:00">Nov 11, 2020 at 11:25am PST</time></p></div></blockquote><p></p><blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/CHduL-AJjt5/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13"><div style="padding: 16px;"><p>&nbsp;</p><div style="display: flex; flex-direction: row; align-items: center;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div><div style="padding-top: 8px;"><div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div></div><div style="margin-left: auto;"><div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p>&nbsp;</p><p style="margin: 8px 0 0 0; padding: 0 4px;"><a style="color: #000; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none; word-wrap: break-word;" href="https://www.instagram.com/p/CHduL-AJjt5/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer">Sitting with a heavy heart&#8230;..RIL (god son) mannnnnn&#8230;&#8230;.#mo3 #mo3badazz</a></p><p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by <a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px;" href="https://www.instagram.com/glambodystudio/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer"> Glam Body Studio Inc.</a> (@glambodystudio) on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2020-11-11T20:46:48+00:00">Nov 11, 2020 at 12:46pm PST</time></p></div></blockquote><p></p><blockquote class="twitter-tweet"><p dir="ltr" lang="en">Rip mo3 &amp; what i think is fucked up is i saw his body on the road &amp; they didn’t cover him even after he was pronounced dead at the scene. He was literally just laying there surrounded by people. I did not record but that shit was horrible to see how they had no respect for him</p><p>— ♚ Luka❍ 12:00 (@luvinorbit) <a href="https://twitter.com/luvinorbit/status/1326656557354987520?ref_src=twsrc%5Etfw">November 11, 2020</a></p></blockquote><p></p><div id="header" class="style-scope ytd-comment-renderer"><blockquote><div id="header-author" class="style-scope ytd-comment-renderer"><span class="style-scope ytd-comment-renderer">FreshLAMane wrote </span><span id="author-reputation" class="style-scope ytd-comment-renderer"></span></div></blockquote></div><blockquote><div id="content" class="style-scope ytd-expander">Sad stuff man, found out about him like two years ago really talented guy, however I study the practice of Gematria which is used by all factions of entertainment industry to ritually sacrifice these artist on very STRATEGIC Dates, to see the actually proof of what I&#8217;m saying check out @seethruthescript for more insight, RIP to this man! Believe me this wasn&#8217;t by accident!</div></blockquote><div></div></div></div></div></div></div><div style="font-size: medium;"><div style="font-size: medium;"><div style="font-weight: 400;"><div style="width: 330px" class="wp-caption alignnone"><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'> <ins class="adsbygoogle"
style="display:block"
data-ad-format="fluid"
data-ad-layout-key="-cx-2d+b-2q+h3"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="6030412800"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><noscript><img alt="Image result for rip" width="320" height="240" data-recalc-dims="1" data-src="https://i1.wp.com/i.pinimg.com/474x/e3/1e/1f/e31e1f9ea2322decd31dfbb8874ee551.jpg?resize=320%2C240&#038;ssl=1" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="/><noscript><img src="https://i1.wp.com/i.pinimg.com/474x/e3/1e/1f/e31e1f9ea2322decd31dfbb8874ee551.jpg?resize=320%2C240&#038;ssl=1" alt="Image result for rip" width="320" height="240" data-recalc-dims="1"/></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20320%20240%22%3E%3C/svg%3E' data-src="https://i1.wp.com/i.pinimg.com/474x/e3/1e/1f/e31e1f9ea2322decd31dfbb8874ee551.jpg?resize=320%2C240&#038;ssl=1" alt="Image result for rip" width="320" height="240" data-recalc-dims="1"/><p class="wp-caption-text"><a href="https://celebritiesdeaths.com/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/">Boosie Badazz Associate and Dallas Rapper Mo3 Shot Dead Today.</a></p></div></div></div></div></div><div id="M579592ScriptRootC938202"></div></p><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-gravatar"><img alt src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=100&#038;d=mm&#038;r=g" class="avatar avatar-100 photo jetpack-lazy-image" height="100" width="100" itemprop="image" data-lazy-srcset="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=200&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=100&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' data-srcset='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=200&#038;d=mm&#038;r=g 2x' height='100' width='100' itemprop="image" data-src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=100&#038;d=mm&#038;r=g" class="avatar avatar-100 photo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="/><noscript><img alt='' src='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' itemprop="image"/></noscript></noscript></div><div class="saboxplugin-authorname"><a href="https://celebritiesdeaths.com/author/admin/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">John Okoro</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p><strong>OUR TEAM</strong></p><h2>JOHN OKORO</h2><p>John Okoro, is a Seasoned Journalist, scriptwriter, Movie producer/Director and Showbiz consultant.</p><p>He is the founder and CEO of the multi Media conglomerate, Celebrities Deaths News, specializing in celebrities deaths news and obituaries</p><p>He is a 2018 He has a degree in Political Science and Mass Communication.</p></div></div><div class="clearfix"></div></div></div><footer class="entry-meta"> <span>Category: <a href="https://celebritiesdeaths.com/category/celebrities-deaths/" rel="category tag">CELEBRITIES DEATHS</a></span> <span></span><div class="author-info"><div class="author-avatar"> <img alt src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=68&#038;d=mm&#038;r=g" class="avatar avatar-68 photo jetpack-lazy-image" height="68" width="68" data-lazy-srcset="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=136&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=68&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' data-srcset='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=136&#038;d=mm&#038;r=g 2x' height='68' width='68' data-src="https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=68&#038;d=mm&#038;r=g" class="avatar avatar-68 photo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="/><noscript><img alt='' src='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=68&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ae9a8cb9f8a50e2420da1e998f121a1c?s=136&#038;d=mm&#038;r=g 2x' class='avatar avatar-68 photo' height='68' width='68'/></noscript></noscript></div><div class="author-description"><h2>About John Okoro</h2><p><strong>OUR TEAM</strong><h2>JOHN OKORO</h2> John Okoro, is a Seasoned Journalist, scriptwriter, Movie producer/Director and Showbiz consultant.  He is the founder and CEO of the multi Media conglomerate, Celebrities Deaths News, specializing in celebrities deaths news and obituaries  He is a 2018 He has a degree in Political Science and Mass Communication.</p><div class="author-link"> <a href="https://celebritiesdeaths.com/author/admin/" rel="author"> View all posts by John Okoro <span class="meta-nav">&rarr;</span> </a></div></div></div></footer></article><nav class="nav-single"><div class="assistive-text">Post navigation</div><span class="nav-previous"><a href="https://celebritiesdeaths.com/andrew-wright-death-dead-obituary-andrew-wright-may-have-passed-away/" rel="prev"><span class="meta-nav">&larr;</span> Andrew Wright Death-Dead  / Obituary : Andrew Wright may have passed away,</a></span> <span class="nav-next"><a href="https://celebritiesdeaths.com/dj-spinbad-death-dead-obituaries-new-york-dj-spinbad-has-died-cause-of-death-unknown/" rel="next">DJ Spinbad Death -Dead-Obituaries : New York  DJ Spinbad has Died &#8211; Cause of Death Unknown. <span class="meta-nav">&rarr;</span></a></span></nav><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/mo3-death-dead-dallas-rapper-mo3-shot-dead-today/#respond" style="display:none;">Cancel reply</a></small></h3><form id="commentform" class="comment-form"> <iframe title="Comment Form" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" data-src="https://jetpack.wordpress.com/jetpack-comment/?blogid=127677342&#038;postid=301612&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.0.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=f984d24527abc21cd337593632fa2a4e2529cede#parent=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F" class="jetpack_remote_comment lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe> <!--<![endif]--></form></div><input type="hidden" name="comment_parent" id="comment_parent" value="" /><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div></div><div id="secondary" class="widget-area" role="complementary"><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-8705305398156930"
data-ad-slot="4505843146"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="M579592ScriptRootC990616"></div></div></aside><aside id="text-2" class="widget widget_text"><p class="widget-title">CONTACTS US</p><div class="textwidget"><p>CONTACT CELEBRITIES DEATHS : 38 MARKET ROAD, ABA, ABIA STATE NIGERIA E-MAIL: jookco @ gmail.com</p></div></aside></div></div><footer id="colophon" role="contentinfo"><div class="site-info"><div class="footercopy">custom footer text left</div><div class="footercredit">custom footer text right</div><div class="clear"></div></div></footer><div class="site-wordpress"> <a href="https://themonic.com/iconic-one/">Iconic One</a> Theme | Powered by <a href="https://wordpress.org">Wordpress</a></div><div class="clear"></div></div><script data-ad-client="ca-pub-8705305398156930" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><noscript><style>.lazyload{display:none;}</style></noscript>     <script id='monsterinsights-frontend-script-js-extra'>var monsterinsights_frontend={"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/celebritiesdeaths.com","hash_tracking":"false"};</script>
<!--[if lt IE 9]><script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/mlc7ey5l/44hrf.js"></script><![endif]-->
<script data-cfasync="false">(window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
var mi_version='7.12.3';
var mi_track_user=true;
var mi_no_track_reason='';
var disableStr='ga-disable-UA-171651658-1';
function __gaTrackerIsOptedOut(){
return document.cookie.indexOf(disableStr + '=true') > -1;
}
if(__gaTrackerIsOptedOut()){
window[disableStr]=true;
}
function __gaTrackerOptout(){
document.cookie=disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr]=true;
}
if('undefined'===typeof gaOptout){
function gaOptout(){
__gaTrackerOptout();
}}
if(mi_track_user){
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
__gaTracker('create', 'UA-171651658-1', 'auto');
__gaTracker('set', 'forceSSL', true);
__gaTracker('require', 'displayfeatures');
__gaTracker('require', 'linkid', 'linkid.js');
__gaTracker('send','pageview');
}else{
console.log("");
(function(){
var noopfn=function(){
return null;
};
var noopnullfn=function(){
return null;
};
var Tracker=function(){
return null;
};
var p=Tracker.prototype;
p.get=noopfn;
p.set=noopfn;
p.send=noopfn;
var __gaTracker=function(){
var len=arguments.length;
if(len===0){
return;
}
var f=arguments[len-1];
if(typeof f!=='object'||f===null||typeof f.hitCallback!=='function'){
console.log('Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason);
return;
}
try {
f.hitCallback();
} catch (ex){
}};
__gaTracker.create=function(){
return new Tracker();
};
__gaTracker.getByName=noopnullfn;
__gaTracker.getAll=function(){
return [];
};
__gaTracker.remove=noopfn;
window['__gaTracker']=__gaTracker;
})();
}</script>
<script src='//celebritiesdeaths.com/wp-content/cache/wpfc-minified/m0oqtr1p/5xw2c.js' id='jquery-core-js'></script>
<script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v8.0&appId=2679667082262512&autoLogAppEvents=1" nonce="oqWdgabD"></script>
<script>document.documentElement.className=document.documentElement.className.replace('no-js', 'js');</script>
<script>document.documentElement.classList.add('jetpack-lazy-images-js-enabled'
);</script>
<script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/q51lnb4d/4b7oq.js"></script>
<script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/1d1x0h4j/bqiv6.js" async></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script async src="//www.instagram.com/embed.js"></script>
<script async src="//www.instagram.com/embed.js"></script>
<script async src="//www.instagram.com/embed.js"></script>
<script async src="//www.instagram.com/embed.js"></script>
<script async src="//www.instagram.com/embed.js"></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/jp89fz6v/bqiv5.js" async></script>
<!--[if IE]><script>if(0===window.location.hash.indexOf('#comment-')){
window.location.hash=window.location.hash;
}</script><![endif]-->
<script src="//celebritiesdeaths.com/wp-content/cache/wpfc-minified/6kkernx1/bqiv5.js" async></script>
<script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script>
<script async data-noptimize="1" src='https://d8a2i3w5.stackpathcdn.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js?ao_version=2.7.8'></script>
<!--[if IE]><script>if(0===window.location.hash.indexOf('#comment-')){
window.location.hash=window.location.hash;
}</script><![endif]-->
<script src='https://stats.wp.com/e-202046.js' async='async' defer='defer'></script>
<script>_stq=window._stq||[];
_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'127677342',post:'301612',tz:'0',srv:'celebritiesdeaths.com'} ]);
_stq.push([ 'clickTrackerInit', '127677342', '301612' ]);</script>
<script>document.addEventListener('DOMContentLoaded', function (){
var commentForms=document.getElementsByClassName('jetpack_remote_comment');
for (var i=0; i < commentForms.length; i++){
commentForms[i].allowTransparency=false;
commentForms[i].scrolling='no';
}});</script>
<script>(function (){
var comm_par_el=document.getElementById('comment_parent'),
comm_par=(comm_par_el&&comm_par_el.value) ? comm_par_el.value:'',
frame=document.getElementById('jetpack_remote_comment'),
tellFrameNewParent;
tellFrameNewParent=function (){
if(comm_par){
frame.src="https://jetpack.wordpress.com/jetpack-comment/?blogid=127677342&postid=301612&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=f984d24527abc21cd337593632fa2a4e2529cede#parent=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F" + '&replytocom=' + parseInt(comm_par, 10).toString();
}else{
frame.src="https://jetpack.wordpress.com/jetpack-comment/?blogid=127677342&postid=301612&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=f984d24527abc21cd337593632fa2a4e2529cede#parent=https%3A%2F%2Fcelebritiesdeaths.com%2Fmo3-death-dead-dallas-rapper-mo3-shot-dead-today%2F";
}};
if('undefined'!==typeof addComment){
addComment._Jetpack_moveForm=addComment.moveForm;
addComment.moveForm=function(commId, parentId, respondId, postId){
var returnValue=addComment._Jetpack_moveForm(commId, parentId, respondId, postId),
cancelClick, cancel;
if(false===returnValue){
cancel=document.getElementById('cancel-comment-reply-link');
cancelClick=cancel.onclick;
cancel.onclick=function (){
var cancelReturn=cancelClick.call(this);
if(false!==cancelReturn){
return cancelReturn;
}
if(! comm_par){
return cancelReturn;
}
comm_par=0;
tellFrameNewParent();
return cancelReturn;
};}
if(comm_par==parentId){
return returnValue;
}
comm_par=parentId;
tellFrameNewParent();
return returnValue;
};}
document.addEventListener('DOMContentLoaded', function (){
var iframe_url="https:\/\/jetpack.wordpress.com";
if(window.postMessage){
if(document.addEventListener){
window.addEventListener('message', function(event){
var origin=event.origin.replace(/^http:\/\//i, 'https://');
if(iframe_url.replace(/^http:\/\//i, 'https://')!==origin){
return;
}
jQuery(frame).height(event.data);
});
}else if(document.attachEvent){
window.attachEvent('message', function(event){
var origin=event.origin.replace(/^http:\/\//i, 'https://');
if(iframe_url.replace(/^http:\/\//i, 'https://')!==origin){
return;
}
jQuery(frame).height(event.data);
});
}}
})
})();</script>
</body></html><!-- WP Fastest Cache file was created in 0.8537380695343 seconds, on 12-11-20 5:58:28 --><!-- need to refresh to see cached version -->